Question

    tofudisan
    Electrify has wi-fi problem with dual-band routers?
    Question posted April 1, 2012 by tofudisanTelegraph , last edited April 4, 2012
    1618 Views, 15 Comments
    Question Title:
    Electrify has wi-fi problem with dual-band routers?
    Comment:

    I got my Electrify back in January 2012.  Recently my home wi-fi router died and I bought a new one (Belkin N750 dual band).  Now my Motorola Electrify won't connect to it.

    I have three laptops and a Samsung phone connecting to the router with no problem.  I can connect my Electrify on other wi-fi routers with no problem at all.

    When I try to connect on my home router the phone goes through the same infinite cycle of scanning/connecting/disconnected (disconnectes are immediate).

    Before you ask the obvious questions:

    1. Yes I have wi-fi turned on on the phone
    2. Yes I'm positive I'm connecting to the correct network
    3. Yes I'm positive I typed the password in correctly
    4. Yes the router is powered on and working properly
    5. Yes I've tried a reset of the router
    6. Yes I've tried deleting the network SSID from the phone and starting over with detecting
    7. Yes I've done a factory reset to the phone and tried again
    8. No I'm not running a custom ROM or any other root modification to the phone
    9. No I don't have any wi-fi manager apps installed.  Stock android wi-fi manager only
    10. Yes other devices connect to the router without issue

    I've done some searching on the web and found other people mentioning problems with wi-fi on the Electrify.  I tried to search the Moto forum for this topic but, quite frankly, the forum interface sucks.  I did find relevant posts via Google though.

     

    https://forums.motorola.com/posts/196fdd1ae1

    https://forums.motorola.com/posts/ec7b8431cf

     

    Answer

     

    • eaccents

      Sorry to hear you are having trouble with connecting to your router.

      I have a dual band router at work (Linksys broadcasts at 2.4Ghz and 5.0Ghz).  My Photon--twin to your Electrify--has no issues with connecting.

      I think it is a setting on the router since your device will connect to other routers without problem.  Additionally, you should know that your device will not even detect the 5Ghz broadcast, so I believe that the Electrify treats dual band routers the same as single band routers.

      I'm not very technical, but at home I had a similar problem and based on something I read here in the forums (someone else had some issues connecting to their router but with a different device), I increased the max number of users in the DHCP Server Setting and now I seem to connect readily.  I was nowhere near the old max in terms of the number of users in our house, so I have no idea why this change would make a difference but it seemed to work....

      Hopefully someone with more router expertise can give you some other options to try :)

    • stef7

      You might want to install something like Netstumbler on one of your PCs and see if you have someone else next door transmitting on the same channel as yourself. Or you can download WiFi Analyzer onto the phone.

       

      Experiments:

      You might want to make sure your settings are such that the 2.4GHz and 5GHz are not using the same SSID and that mixed mode is enabled.

      You might want to try broadcasting your SSID and see if that makes a difference.

      You might want to try changing your protection scheme.

      Does your phone establish a "public" or "open" spot for visitors? Is it enabled? Can you see and connect to that?


      Perhaps you need to have the phone replaced?

    • nicholas9543

      Similar to my problem. I use a widget to turn mine on, usually takes less than 10 seconds to connect. Mine hangs on obtaining ip address. It only works for some reason in the wifi settings. I have no clue why. It happens on all access points. I have cleared cache before barely any luck. Yell I hope ICS fixes this problem for good, it becomes anoying fast.

    • hewlett

      Sorry to hear about the router connections eccents,but have you tried:

      1: connecting from Motorla phone portal first on your phone and computer.

      2: connect with WiFi settings and seach for your router .

       hope it helps.

    • stef7

      @nicholas9543 - I suppose I'd try one Factory Data Reset, and if that didn't work, I'd get the phone replaced. Of course, a FDR is going to cause you to loose information from your device. It's easy to export and re-import contacts, but much less trivial to install programs and utilities and enter in email addresses and settings.

    • eaccents
      hewlett said:

      Sorry to hear about the router connections eccents,but have you tried:

      1: connecting from Motorla phone portal first on your phone and computer.

      2: connect with WiFi settings and seach for your router .

       hope it helps.

      @hewlett

      Thanks for the advice :)

      I was able to resolve my issue by increasing the max number of DHCP server setting from 50 to 100.  Now my device seems to connect without hesitation.

    • hewlett

      That's Fantastic ! Also I have used the DLNA function on this phone to seach for my router with great success.

    • stef7

      And did the OP have more than 50 devices? I missed something - is the router just not serving up IPs like it should, or did the OP have a lot of devices on the local net? Glad it's resolved.

    • eaccents
      stef7 said:

      And did the OP have more than 50 devices? I missed something - is the router just not serving up IPs like it should, or did the OP have a lot of devices on the local net? Glad it's resolved.

      Sorry, have no idea.  

      We made this change at work, and it helped with the issue of not connecting to the router.  So I made the same change at home (where there are nowhere near 50 users) and it seemed to help as well.  I do not know enough about routing to say why [yeah, doesn't make sense to me either] but it worked. [shrug]

    • tofudisan
      stef7 said:

      And did the OP have more than 50 devices? I missed something - is the router just not serving up IPs like it should, or did the OP have a lot of devices on the local net? Glad it's resolved.

      Not resolved.  Don't know where you got the impression that it's resolved.  Still can't connect with my phone.

      No I do not have too many devices.  My phone just loops through connecting/disconnecting.  There's only 3 client IPs (two laptops and one phone).  My phone doesn't stay connected long enough.

    • tofudisan
      eaccents said:

      Sorry to hear you are having trouble with connecting to your router.

      I have a dual band router at work (Linksys broadcasts at 2.4Ghz and 5.0Ghz).  My Photon--twin to your Electrify--has no issues with connecting.

      I think it is a setting on the router since your device will connect to other routers without problem.  Additionally, you should know that your device will not even detect the 5Ghz broadcast, so I believe that the Electrify treats dual band routers the same as single band routers.

      I'm not very technical, but at home I had a similar problem and based on something I read here in the forums (someone else had some issues connecting to their router but with a different device), I increased the max number of users in the DHCP Server Setting and now I seem to connect readily.  I was nowhere near the old max in terms of the number of users in our house, so I have no idea why this change would make a difference but it seemed to work....

      Hopefully someone with more router expertise can give you some other options to try :)

       It's not the router.  Literally every other device can connect to the router without an issue.  Just my phone cannot.  The phone does indeed only see the 2.4Ghz band and not both.  The max connections on the router is left to the default of 97 connections (192.168.2.2 to 192.168.2.100) and there are only 4 connections currently (2 laptops, desktop and my wife's phone).  So it's not the number of connections.

      It's the phone in my opinion.  Especially after reading about other people having the same problem with the same phone.

    • tofudisan
      stef7 said:

      You might want to install something like Netstumbler on one of your PCs and see if you have someone else next door transmitting on the same channel as yourself. Or you can download WiFi Analyzer onto the phone.

       

      Experiments:

      You might want to make sure your settings are such that the 2.4GHz and 5GHz are not using the same SSID and that mixed mode is enabled.

      You might want to try broadcasting your SSID and see if that makes a difference.

      You might want to try changing your protection scheme.

      Does your phone establish a "public" or "open" spot for visitors? Is it enabled? Can you see and connect to that?


      Perhaps you need to have the phone replaced?

      Both channels have different SSIDs assigned and they're both broadcasting already.  Both have been set to 802.11n only.  I've tried removing any encyrption levels entirely.  We're a fairly rural neighborhood so there's nobody nearby.  My devices don't even see any other networks other than mine.  The phone is not set to be a hotspot (not even enabled).

      I really do think it's the wireless software with this phone.  I can see the signal.  The strength is strong (and not just when I'm planted right next to the router).  The phone simply connects and immediately disconnects.  Very irritating.

    • tofudisan
      stef7 said:

      @nicholas9543 - I suppose I'd try one Factory Data Reset, and if that didn't work, I'd get the phone replaced. Of course, a FDR is going to cause you to loose information from your device. It's easy to export and re-import contacts, but much less trivial to install programs and utilities and enter in email addresses and settings.

       

      @nicholas9543 as said in the orignal post I did try a factory reset.

    • eaccents
       is "enable auto ip" enabled? this is in advanced wifi settings menu.
    • stef7

      @tofudisan: somehow you got lost in the sauce... ok, if "enable auto ip" doesn't work for ya, try one more experiment.

       

      change the router to "mixed mode"; i.e. do not set up both for "IEEE802.11n".

       

      report back.