DROID RAZR M by Motorola

Verizon Wireless

Question

    phositadc
    Delayed Google (talk, mail) notifications on wifi
    Question posted September 26, 2012 by phositadcPager (25+ points) 
    1000 Views, 31 Comments
    Question Title:
    Delayed Google (talk, mail) notifications on wifi
    Comment:

    My Gmail and Google Talk notifications are delayed on wifi when my screen is off. When I'm actively using the phone and my screen is on, there is no delay. Typical delay when screen is off is 3-5 minutes. However, I've seen delays as long as 20 minutes. Strange thing is, the delay kicks in literally the second I turn my screen off. For instance, I can be sitting and using the phone, turn it off, and then one second later send myself a Gtalk message, and the message won't come in for 3-5 minutes.

    If I turn my screen on during this "delay period," all of the notifications immediately show up. So it's almost like the phone is going into some reduced wifi sensitivity mode the instant I turn the screen off.

    For the record, my wife's Galaxy Nexus always gets Gmail and Gtalk notifications instantly when on wifi (yes, including the same wifi network that is giving me problems).

    The only fix I've attempted so far is setting my phone's wifi to 2.4 ghz only, which did not seem to change anything. I already have the phone's wifi set to "Always" on. I do not have any power saving features turned on (no juice defender, no smart actions, etc.).

    Any advice?  Thanks.

    Edit: Oh, and my router is an Apple Airport Express (as part of a Time Capsule).  (see below: I've now also tried an Actiontec router, and I get the same delays).

    Edit #2: In case it was not clear, I'm not looking for a way to keep my screen on.  I'm looking for a way to get timely Google notifications even when my screen is off, i.e., the phone is in standby.

    Also, I tried connecting it to another wifi network using the router provided to me by Verizon.  It is an Actiontec router.  I get exactly the same delays when connected to it as I do when connected to my Airport.  So it does not seem to be a problem with the Airport.

    Answer

    • DansDroid

      Under settings > display > sleep > have you tried the "never timeout" option?    --- Dan

    • phositadc

      Well, first of all, I don't have a "never timeout" option.  10 minutes is the longest I have.

      Second, even if I did have that option, it would keep my display on forever, which is clearly not a viable solution.

      I should be able to get timely notification on wifi even when my screen is off.

       

    • DansDroid
      phositadc said:

      Well, first of all, I don't have a "never timeout" option.  10 minutes is the longest I have.

      Second, even if I did have that option, it would keep my display on forever, which is clearly not a viable solution.

      I should be able to get timely notification on wifi even when my screen is off.

       

      View original


      Understood.  I thought there would be more consistency with ICS on the time out variables.  I was accustomed to it on various devices with Gingerbread, but still wonder why it wasn't/isn't consistent now.  There's something I'm overlooking, but with the collective knowledge pool we have on the forum, I'm certain they'll come up with a solution.   --- Dan

    • Matt (Forums Manager)

      What do you have set for Wi-Fi behaviour under Settings > Wi-Fi > Menu > Advanced > Keep Wi-Fi on during sleep?

    • phositadc
      Matt (Forums Manager) said:

      What do you have set for Wi-Fi behaviour under Settings > Wi-Fi > Menu > Advanced > Keep Wi-Fi on during sleep?

      View original

      Keep wifi on during sleep is set to "Always."  And, as I mentioned, I do get the notifications after several minutes.  If it were set to "never," presumably I would never get the notifications until the screen is turned on, which is not the case.

    • Matt (Forums Manager)
      phositadc said:
      Matt (Forums Manager) said:

      What do you have set for Wi-Fi behaviour under Settings > Wi-Fi > Menu > Advanced > Keep Wi-Fi on during sleep?

      View original

      Keep wifi on during sleep is set to "Always."  And, as I mentioned, I do get the notifications after several minutes.  If it were set to "never," presumably I would never get the notifications until the screen is turned on, which is not the case.

      View original

      If Wi-Fi is off, and you are using LTE/3G, does the behaviour change? This is interesting...

    • phositadc
      Matt (Forums Manager) said:
      phositadc said:
      Matt (Forums Manager) said:

      What do you have set for Wi-Fi behaviour under Settings > Wi-Fi > Menu > Advanced > Keep Wi-Fi on during sleep?

      View original

      Keep wifi on during sleep is set to "Always."  And, as I mentioned, I do get the notifications after several minutes.  If it were set to "never," presumably I would never get the notifications until the screen is turned on, which is not the case.

      View original

      If Wi-Fi is off, and you are using LTE/3G, does the behaviour change? This is interesting...

      View original

      Yep, if I'm just using 4G or 3G, everything comes in immediately -- no delay problems whatsoever.  Delay problem only occurs on wifi.

      By the way, in case its relevant, I'm using WPA2 encryption on my router.

    • Matt (Forums Manager)

      Okay -- now I'm confused.

      First, how are you telling that there's a delay and how long it lasts?

      Second, if the notifications show up instantly once the screen is turned on, what's the damage.

      What am I missing?

    • phositadc
      Matt (Forums Manager) said:

      Okay -- now I'm confused.

      First, how are you telling that there's a delay and how long it lasts?

      Second, if the notifications show up instantly once the screen is turned on, what's the damage.

      What am I missing?

      View original

      Here's how I know there's a delay.  Phone is on; screen is off.  I pick up my wife's phone, or I log in to a gmail account from a computer, and I send a Google Talk message or a Gmail to my phone.  Phone sits there and does nothing.  3, 4, 5... sometimes up to 20 minutes later, phone FINALLY plays a notification sound letting me know that it received the Gtalk or the Gmail.

      Second, isn't the whole point of notification sounds to let you know that you have a new email or message without having to turn my screen on to check every 5 minutes? So the damage is that I have no idea I got a new email or message unless I actively turn my phone on every few minutes and check.  Again, sometimes 20 minutes will pass, and an email or a message is just waiting for me, and I have no idea its there because the notification is so delayed because the phone is so delayed in receiving it while on wifi.

      Sorry if I was unclear, but hopefully that makes it perfectly clear.

      And yes, if I never connect to wifi and just always leave it on 3G or 4G, then the notification delay problem goes away -- everything comes in within a few seconds of when it is sent.  But giving up wifi is not a viable solution.

      Edit: Oh, and just to be clear, I do not think it's just a notification sound issue.  I think my phone actually does not receive the email or the message until the notification sound finally plays.  For instance, frequently I will turn the screen on after it has been off for awhile, and 3 or 4 messages and emails will all flood in at once.

    • phositadc

      By the way, I initially discovered the delay because I would hear my notification sound and see a new Gmail, and on a few occasions I noticed that the time-stamp on the Gmail was actually 10 or 15 minutes sooner than the notification sounded.  That was initially what made me suspicious that my emails and messages were delayed on wifi, and since then, I have been testing it myself.

      And here's a short video I took of the issue: http://youtu.be/g8f6AHJ4VqQ

      Obviously, I did not wait several minutes for the notification to arrive, but the video shows the following: 1) me sending a Gtalk message from my computer to my Razr M; 2) me waiting 15 or 20 seconds; 3) no message arriving on the Razr M; 4) the message arriving as soon as I turn the Razr M's screen on.

      In the video I only wait 15 or 20 seconds, but I can assure you that I could wait 3, 4, 5 minutes, and the message would not arrive.  Sometimes as long as 20 minutes.  But if I turn the screen on, the message arrives right away.  Again, this is problematic because I need to receive my message notifications quickly without having to constantly turn my screen on to check if any new messages come in.

      Please let me know if I'm being unclear.  And any other M owners, please connect to your wifi and send yourself a Gmail or a Gtalk message and see if you get the same delays when your screen is off.

    • jntdroid

      Per your request over at DF...

      Gmail showed up instantly.

      Gtalk is another matter.  But Gtalk has always been finicky b/c it has to sync between devices and keep the threads updated.  

      My wife and I have been chatting via Gtalk this morning for the first time in months, coincidentally (we normally use WL Messenger).  The only time I've had ANY gtalk notification show up on my phone was AFTER I first typed to her in gtalk on my phone.  As soon as I started using the computer again, all gtalk notifications on my phone stopped.  For what it's worth, I'm using the actual Gtalk desktop app, not the one embedded in gmail.

    • phositadc
      jntdroid said:

      Per your request over at DF...

      Gmail showed up instantly.

      Gtalk is another matter.  But Gtalk has always been finicky b/c it has to sync between devices and keep the threads updated.  

      My wife and I have been chatting via Gtalk this morning for the first time in months, coincidentally (we normally use WL Messenger).  The only time I've had ANY gtalk notification show up on my phone was AFTER I first typed to her in gtalk on my phone.  As soon as I started using the computer again, all gtalk notifications on my phone stopped.  For what it's worth, I'm using the actual Gtalk desktop app, not the one embedded in gmail.

      View original

      Thanks a lot for the reply.  For me, both Gmail and Gtalk are delayed.  

      Oh, and the behavior you describe with Gtalk is normal.  If you are using multiple devices it will "figure out" which device you are actually using, and it will stop giving you notifications on your other devices until you pick one of them up and start using it.

    • jntdroid

      That's odd - have you tried clearing the data in the gmail and gtalk apps?  Just to kinda start those two from scratch?  Do other notifications (texts, missed calls, email from other accounts, voicemails, etc.) all seem to work fine?

    • phositadc
      jntdroid said:

      That's odd - have you tried clearing the data in the gmail and gtalk apps?  Just to kinda start those two from scratch?  Do other notifications (texts, missed calls, email from other accounts, voicemails, etc.) all seem to work fine?

      View original

      Haven't tried clearing data -- I'll try that before I factory reset.  Good idea.

      And yeah other notifications seem to work fine.  Just seems to be delays on accounts connected to google services.

    • DansDroid
      Matt (Forums Manager) said:
      phositadc said:
      Matt (Forums Manager) said:

      What do you have set for Wi-Fi behaviour under Settings > Wi-Fi > Menu > Advanced > Keep Wi-Fi on during sleep?

      View original

      Keep wifi on during sleep is set to "Always."  And, as I mentioned, I do get the notifications after several minutes.  If it were set to "never," presumably I would never get the notifications until the screen is turned on, which is not the case.

      View original

      If Wi-Fi is off, and you are using LTE/3G, does the behaviour change? This is interesting...

      View original


      *That's* the menu I was looking for earlier when I went under "display"...smacking self on forehead.  crying   --- Dan